Was bedeutet der Fehler 10054?
Der Fehler 10054 kann auf eine falsche System-, Firewall- oder Routerkonfiguration zurückzuführen sein.
Symptom
Die Verbindung wird unterbrochen und Sie erhalten den Windows-Socket-Fehler 10054.
Ursache
Der Fehler 10054 tritt auf, wenn die Verbindung von der Peer-Anwendung zurückgesetzt wird, was in der Regel auf eine falsche Firewall-Konfiguration zurückzuführen ist. Weitere Informationen zu diesem Fehler finden Sie im Microsoft Development Center.
Lösung 1: Überprüfen Sie, ob die Domänen in Ihrer Firewall/Router-Konfiguration zugelassen sind
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Lösung 2: Befindet sich der Computer hinter einer Sonic Firewall oder einer anderen Art von Firewall? Möglicherweise blockiert Ihre Intrusion Detection die Anwendung.
- Deaktivieren Sie vorübergehend alle Funktionen im Zusammenhang mit der Intrusion Detection.
- Versuchen Sie erneut, eine Verbindung herzustellen, um zu prüfen, ob die Intrusion Detection den Host-Dienst beeinträchtigt.
- Wenn das Problem weiterhin besteht, fahren Sie mit Lösung 3 fort.
Lösung 3: Deaktivieren der Peer-to-Peer-Funktionalität in der Anwendung
Auf bestimmten Systemen tritt das Problem auf, wenn die Anwendung über eine Peer-to-Peer-Verbindung verbunden ist. Um diese Funktion zu deaktivieren, müssen Sie einen Registrierungsschlüssel bearbeiten.
- Gehe zu .
- Geben Sie regedit ein und drücken Sie die Eingabetaste.
- Navigieren Sie zu dem folgenden Ordner: HKEY_LOCAL_MACHINE\SOFTWARE\LOGMEIN\V5\Net\NATUDP
- Ändern Sie den Schlüssel DisableEx (REG_DWORD) von 0 auf 1.
- Schließen Sie den Registrierungseditor.
- Gehe zu .
- Geben Sie services.msc ein und drücken Sie die Eingabetaste.
- Suchen Sie den Host-Dienst.
- Klicken Sie auf Neu starten.
- Stellen Sie die Verbindung über den Host wieder her und prüfen Sie, ob die Verbindung weiterhin unterbrochen wird.
Wenn das Problem weiterhin besteht, wenden Sie sich an den GoTo Support.